News: Celebrating over 10 years serving the creative community

Author Topic: [Modeling Help] Milkshape 3d crashes when i compile a model  (Read 3679 times)

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Hello, i recently hacked a new mp5 model onto the op4 redux human grunts, and everytime i try to compile it ms3d crashes (i also tried with jeds half life model viewer and that crashes too), any solutions?

NOTE: It didint crash when i hacked the mp5 onto romkas op4 human grunts and the normal op4 human grunts, do you think its a problem with just that model?
« Last Edit: July 13, 2013, 10:25:38 PM by CounterLogic »

SPRKH

  • Cry of Fear Team
  • Big Momma
  • *
  • Posts: 703
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #1 on: July 13, 2013, 11:50:25 PM »
There should be a progress log in the bottom-left corner when compiling in Milkshape, the error should be written down in there.

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #2 on: July 14, 2013, 05:03:41 AM »
There should be a progress log in the bottom-left corner when compiling in Milkshape, the error should be written down in there.
It just crashes after it attempts to write hgrunt_opforT.

Besli

  • HoE Project
  • Baby Gargantua
  • *
  • Posts: 454
  • Mr. Database
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #3 on: July 14, 2013, 05:40:31 AM »
Make sure that all the textures do have 256 colours (8bit).
If you don't like it, mod it! (DaniJ)

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #4 on: July 14, 2013, 06:26:58 AM »
Make sure that all the textures do have 256 colours (8bit).
Thanks, i checked and all the textures bit depth is eight.
« Last Edit: July 14, 2013, 06:33:20 AM by CounterLogic »

Besli

  • HoE Project
  • Baby Gargantua
  • *
  • Posts: 454
  • Mr. Database
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #5 on: July 14, 2013, 11:10:00 AM »
Thanks, i checked and all the textures bit depth is eight.

And did it compile now?
If you don't like it, mod it! (DaniJ)

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #6 on: July 14, 2013, 11:49:25 AM »
And did it compile now?

Unfortunately No...

SPRKH

  • Cry of Fear Team
  • Big Momma
  • *
  • Posts: 703
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #7 on: July 14, 2013, 07:52:57 PM »
Try removing $externaltextures in the qc.

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #8 on: July 14, 2013, 11:14:24 PM »
Try removing $externaltextures in the qc.
I tried that and it still crashes.
« Last Edit: July 15, 2013, 02:20:44 AM by CounterLogic »

SPRKH

  • Cry of Fear Team
  • Big Momma
  • *
  • Posts: 703
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #9 on: July 15, 2013, 10:22:06 AM »
You probably messed something up. Try decompiling the OP4 redux grunt again, and see if that helps. Otherwise post the files.

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #10 on: July 15, 2013, 11:28:42 PM »
You probably messed something up. Try decompiling the OP4 redux grunt again, and see if that helps. Otherwise post the files.
Here you go. https://www.dropbox.com/s/0qq1lxgej73ho06/mp5.rar

SPRKH

  • Cry of Fear Team
  • Big Momma
  • *
  • Posts: 703
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #11 on: July 16, 2013, 12:27:11 AM »
The MP5 smd has over 3.7k triangles, which is too much. You'll need to find a way to reduce it.

/e Here actually, took only 10 seconds anyway

https://dl.dropboxusercontent.com/u/3744945/mp5.SMD
« Last Edit: July 16, 2013, 12:31:47 AM by Sporkeh »

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #12 on: July 16, 2013, 03:25:54 AM »
The MP5 smd has over 3.7k triangles, which is too much. You'll need to find a way to reduce it.

/e Here actually, took only 10 seconds anyway

https://dl.dropboxusercontent.com/u/3744945/mp5.SMD
Thanks, but when i copy pasted it gave me this error

************ ERROR ************
.\/end not found

Editor

  • Administrator
  • Gman
  • *****
  • Posts: 1321
  • Some nerd
    • Half-Life Creations
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #13 on: July 16, 2013, 04:01:21 AM »
Code: [Select]
$bodygroup "weapons"
{
studio "[b]hgrunt_MP5_BMS[/b]"
studio "PC_soldier_new_SPAS12_reference"
studio "PC_soldier_new_SAW_reference"
blank
}

I'm guessing you changed the name of the smd or the name referenced in the qc file to match each other?

Lateralus

  • Pit Drone
  • *****
  • Posts: 208
    • www.titsassesanddicks.cum
Re: [Modeling Help] Milkshape 3d crashes when i compile a model
« Reply #14 on: July 16, 2013, 04:30:24 AM »
Code: [Select]
$bodygroup "weapons"
{
studio "[b]hgrunt_MP5_BMS[/b]"
studio "PC_soldier_new_SPAS12_reference"
studio "PC_soldier_new_SAW_reference"
blank
}

I'm guessing you changed the name of the smd or the name referenced in the qc file to match each other?
Yes that is correct.