News: Celebrating over 10 years serving the creative community

Author Topic: [Mapping Help] BSPedit: "Host_Error: no precache:"  (Read 1968 times)

LeonelC

  • Roach
  • *
  • Posts: 20
[Mapping Help] BSPedit: "Host_Error: no precache:"
« on: August 05, 2013, 06:44:34 AM »
Like the title says, I'm starting up to use BSPedit (it's kinda like an "easy" version of ripent, judging by comparing both programs) just to try to replace some brushes with models, the classic case of "I want to replace those blocky health chargers with a prop model".

But I have this problem "Host_Error: no precache: models/health_charger.mdl" when I'm running the map, and I really have no clue of what I have to do (I know almost nothing about anything involved with .bsp files).

Searching a bit most of the solutions were to remove some entities, but I don't want to alter original Half-Life THAT much.

¿Can you guys lend me a hand with this?

Alex

  • For Hire A
  • Gman
  • *
  • Posts: 2057
Re: [Mapping Help] BSPedit: "Host_Error: no precache:"
« Reply #1 on: August 05, 2013, 08:32:22 AM »
The clur is in the error message  :sagan:

It means that you've added a model to the map, but it isn't in the /models/ directory

LeonelC

  • Roach
  • *
  • Posts: 20
Re: [Mapping Help] BSPedit: "Host_Error: no precache:"
« Reply #2 on: August 05, 2013, 08:59:16 PM »
I tried everything, adding more "/" and/or "\" to the directory of the model, even adding a subfolder with the model in it, but it just throws me the error like the model doesn't exist. :(

D3ads

  • Baby Gargantua
  • ******
  • Posts: 432
  • Stoj! Opasna Zona!
    • Moddb Profile
Re: [Mapping Help] BSPedit: "Host_Error: no precache:"
« Reply #3 on: August 06, 2013, 01:23:32 AM »
It needs to be "HL-directory/valve/models/health_charger.mdl in order for it to work.

LeonelC

  • Roach
  • *
  • Posts: 20
Re: [Mapping Help] BSPedit: "Host_Error: no precache:"
« Reply #4 on: August 24, 2013, 12:03:12 AM »
I tried with everything, I just managed  to make some npcs load other heads, even make them load new ones, y also replaced the intro barney with HL2's Calhoun, but I can't do this D:

This is the code I want to edit:

}
{
"model" "*27"
"classname" "func_healthcharger"
}
{

Now I don't have a clue what to do, I just replaced the route "*27*" with the directory of the model (models/health_charger.mdl), but it throws me that "No precache" error.