News: Celebrating over 10 years serving the creative community

Author Topic: [SC] Hgrunt_opfor some problems  (Read 1905 times)

Rikrdo

  • New Member
  • Posts: 2
[SC] Hgrunt_opfor some problems
« on: March 19, 2010, 02:37:40 AM »
Hello everyone, I need help with this model LD hgrunt of HL but with animations of OP4.
Curiously, in the op4 going great but some alterations occurs in the sven.
Please, I could someone explain what happens, I thank you beforehand.

P.S.

I show them some pictures and model.

Burd!

  • Global Moderator
  • Big Momma
  • ****
  • Posts: 652
Re: [SC] Hgrunt_opfor some problems
« Reply #1 on: March 19, 2010, 02:43:47 AM »
Well, in SC4, there are 84 animations on the Hgrunt, while the O4 grunt has 72. You need to account for the extra rpg and other weapon animations if you want that same Hgrunt model to work well in SC4.

Rikrdo

  • New Member
  • Posts: 2
Re: [SC] Hgrunt_opfor some problems
« Reply #2 on: March 19, 2010, 02:53:22 AM »
Well, in SC4, there are 84 animations on the Hgrunt, while the O4 grunt has 72. You need to account for the extra rpg and other weapon animations if you want that same Hgrunt model to work well in SC4.

thanks, but this model is for SC3.

Burd!

  • Global Moderator
  • Big Momma
  • ****
  • Posts: 652
Re: [SC] Hgrunt_opfor some problems
« Reply #3 on: March 19, 2010, 02:57:20 AM »
I don't happen to have SC3 installed on me, sorry. In your case, open the original SC3 Hgrunt compile and see the orderings and number of sequences there are in the animations tab in Jeds. Compare that to your LD compile, and change respectively.

It might be worth checking to see if both the SC3 and your LD compile may have the same vertices assignment on the rigs, you might not even need to rig anything at all if all the bones are assigned.

Simon

  • BSR Team
  • Baby Gargantua
  • *
  • Posts: 473
  • Whiskey brony
Re: [SC] Hgrunt_opfor some problems
« Reply #4 on: March 19, 2010, 08:40:03 AM »
Try to hack the ld model to the sven original hgrunt skeleton, to me it looks like that you moved a bone so it's better to rering the whole mesh again

Editor

  • Administrator
  • Gman
  • *****
  • Posts: 1321
  • Some nerd
    • Half-Life Creations
Re: [SC] Hgrunt_opfor some problems
« Reply #5 on: March 19, 2010, 10:17:16 PM »
Try to hack the ld model to the sven original hgrunt skeleton, to me it looks like that you moved a bone so it's better to rering the whole mesh again

Yeah I was going to say, order of animations usually does not cause that kind of wackyness. In my experience its from accidentally selecting a bone when rigging.

Simon

  • BSR Team
  • Baby Gargantua
  • *
  • Posts: 473
  • Whiskey brony
Re: [SC] Hgrunt_opfor some problems
« Reply #6 on: March 19, 2010, 11:35:29 PM »
Yeah I was going to say, order of animations usually does not cause that kind of wackyness. In my experience its from accidentally selecting a bone when rigging.
Animation order doesn't do jack shit to moster model since the game looks for them by name, animation order is only important for weapons when the game will look for weapon's animation by order.